SigNoz Usage Issue in China Due to GFW

TLDR Mario is facing challenges with SigNoz in AWS CN due to the Great Firewall (GFW) blocking resources. They asked for potential ways around this. Srikanth explained the consequences of missing dependencies.

Photo of Mario
Mon, 25 Sep 2023 12:48:02 UTC

Hi everyone :wave: My team is assessing the usage of SigNoz. We released it to our AWS EKS clusters following the docs instructions (we took the freedom to rely on ADOT add-on rather than installing OpenTelemetry manually) and so far the tool seems to do what it says it does, very cool :+1: One relevant exception is our cluster in a Chinese region. AWS CN brings its own challenges for being behind the Great Firewall (GFW); many resources (regardless of SigNoz) which presume free internet connection to the wider internet tend to :boom: quickly there. One of these in SigNoz-land is the UDF init container for Clickhouse, it tries to pull histogramQuantile via wget and GFW says no. If I read the correctly (and please correct me if I'm wrong here), you can either enable or disable this dependency, you can even override the default docker image with a custom one (which we have prepared) but we haven't found a way to switch off the default `command` block which tries to pull histogramQuantile. So I was searching a way around this, ideas that came to mind (which would involve changes in the way the template is provided) are: • provide the option to override `command` under UDF (so we could mute it, or make the `wget` call point to a custom location, eg a S3 reachable from CN); • switch off UDF (`enabled: false`) and use a custom init container block (to be added in template) to allow a final user to provide a custom solution; If you think there is already a way around this issue let me know. Final question: what do we lose without this init-container dependency and the histogramQuantile file? Thanks :pray:

Photo of Srikanth
Tue, 26 Sep 2023 01:54:13 UTC

> what do we lose without this init-container dependency and the histogramQuantile file? You won’t be able to use histogram quantiles `hist_quantile_99` etc.. without this.